Laurcons Sites and Services
Status
Back
Maintenance
Site upgrade
Completed 12 Oct at 12:00am EEST.
Affected services
Personal Page (laurcons.ro)
Completed
Maintenance completed
Posted 12 Oct at 12:00am EEST.
Started
Upgrading portfolio website.
Posted 11 Oct at 10:00pm EEST.